[linux-lvm] Help: Mount point does not report full size of LV.

Bryn M. Reeves breeves at redhat.com
Wed Feb 28 16:34:36 UTC 2007

Hash: SHA1

Nick Gyma wrote:
> Hey all, linux n00b here runing ubuntu:
> I added a 3rd hdd to my system today and tried to extend the logical
> volume i currently had with the new added space. it was previously a
> windows NTFS disk (formatted clean before transfer). after going through
> the steps it all displays properly under "vgdisplay -v" but when i
> actually go and check the mount point folder size it is still the same
> as before and has not increased along w/ the volume group and logical
> volume.

Sounds like you just need to tell the file system to grow into the new
space - lvresize or lvextend *only* affect the block device (logical

> I've tried to remove the hdd from the VG to try and redo it but i get
> errors when trying to use "vgreduce" to remove the PV, saying "physical
> volume "dev/hdd1" still in use", even after running a "pvmove" command
> which resulted in "no extents avail for allocation".

Careful with that! Although in this case it should be safe, reducing a
block device with a file system on it is potentially risky - if you get
the size wrong, you can chop the end off & loose data.

> Is there a way to fix the LV as it is so that the mount point
> /home/nick/video is correct? or should i wipe it all out and start over?
> if so, how do i go about doing that? do i delete all data on the LV then
> do a vgremove then fdisk everything, deleting all partitions and start
> over?

By the sound of it, the lvextend worked - does lvdisplay show the
correct (new) size for the logical volume?

If it does, you now need to resize the file system it contains. Since
this was NTFS, you'll need to use the ntfsresize tool for this:


To grow the fs to fit the new device size, you just need to do:

# ntfsresize /path/to/lv

Note that the file system must be unmounted for this step.

Your distribution may provide ntfsresize with the tools to work with
NTFS file systems. If not, you can use a rescue CD that includes it.
I've had good results with systemrescuecd in the past:


Kind regards,

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the linux-lvm mailing list