[linux-lvm] device /dev/sdb1 not found or ignored by filtering

xdub xdub at laposte.net
Thu May 8 08:56:55 UTC 2008


No sure what you want to do with your 2 raid1 arrays... and
why you want to incorporate the first one into LV (?).

Did you partition your second array ? if not, you can create a PV
like this: pvcreate /dev/sdb. "pvcreate" can initialize a disk or partition.

    - pvcreate /dev/sdb
    - vgcreate vg00 /dev/sdb

Again, no sure what you want to do, but with 4 HD you should consider
to build raid5 (hardware raid) and then create PV, VG, LV.


Gilles Guiot wrote:
> Hello Everybody
> I have two raid 1 arrays on a Dell PowerEdge 2950,
> 1) 2*500 Go
> 2) 2*750 Go
> I need to use LVM, to create a LV on the second raid array, in which i 
> will afterwards incorporate the first raid array. I have the latest 
> debian distro installed, with kernel updates, and LVM2 is installed.
> I encounter my first problem when typing pvcreate /dev/sdb1. ( the 
> partition of the second raid array) I get the message :
> device /dev/sdb1 not found or ignored by filtering
> I checked /etc/lvm/lvm.conf, and I commented out the line about the 
> filter.
> After a reboot, no more luck. I tried to circumvent the problem by 
> booting with an ubuntu CD, but i get the same error message.
> Could anybody tip me about what's wrong and more importantly suggest 
> solutions to me ? :-)
> Thanks a lot in advance.

More information about the linux-lvm mailing list