[linux-lvm] Problems growing a logical volume with LVM tools.

malahal at us.ibm.com malahal at us.ibm.com
Mon Sep 22 21:30:55 UTC 2008

vinai [vroopcha at mcw.edu] wrote:
> - And finally (or so I thought) I ran lvextend to resize the logical 
> volume.  But here's where I ran into issues.  Here's the command I've been 
> trying and the output:
> # lvresize -d -v -l 1668910  /dev/array2/rd2
>     Finding volume group array2
>     Archiving volume group "array2" metadata (seqno 4).
>   Extending logical volume rd2 to 6.37 TB
>     Creating volume group backup "/etc/lvm/backup/array2" (seqno 5).
>     Found volume group "array2"
>     Found volume group "array2"
>     Loading array2-rd2 table
>   device-mapper: reload ioctl failed: Invalid argument
>   Failed to suspend rd2

Does de-activating the volume group and then re-activating and then
resizing the lv (or shutdown the machine in the worst case) work? Looks
like there is a known issue with block device resize. I am not sure if
you are hitting that though.


More information about the linux-lvm mailing list