[linux-lvm] Problems growing a logical volume with LVM tools.

vinai vroopcha at mcw.edu
Sat Sep 20 15:18:11 UTC 2008

Hi Folks,

I've been using Linux SuSE and openSUSE for a little while now, but this 
is my first foray into LVM.  This message was originally posted to an 
openSUSE list, but it was suggested to ask a crowd better versed in lvm.

First off - the setup is a rack-mounted server running 64-bit openSUSE 
10.3, with all updates installed.  There are 16 hard drives are split 
up into 2 8-disk RAID-5 volumes using a 3ware SATA RAID controller card. 
Each volume was made up of disks that were previously 400 GB, but now 
upgraded to 1 TB, hence the total volume size grew from 2.4 TB to 6.3 
TB.  The initial setup on this machine did not include LVM, and I would 
like to implement it to handle future size increases.  But I am stuck at 
the final step of extending the logical volume.  Here's what I did so 

- On the 6.3 TB RAID-5 volume, I created a partition (with parted, type 
GPT, with the lvm flag on).  This partition was 2.4 TB (or thereabouts) 
in size, to simulate the growth from 2.4 to 6.3 TB (we were previously 
able to grow the underlying RAID-5 volume successfully).

- I made this partition (sdc1) a physical volume.

- I then made a volume group (array2) from this single partition

- After that, I made a logical volume (rd2) from the array2 volume group

- I used parted and mkfs on this logical partition (rd2) to create a 
partition with the "loop" label and format it.

- I put some data on there and ran a checksum.

- Then I unmounted the rd2 logical partition from the computer's file 

- I ran pvresize on it and maxed out the number of extents available on 
the physical volume successfully.

- I repeated the same for vgresize successfully.

- And finally (or so I thought) I ran lvextend to resize the logical 
volume.  But here's where I ran into issues.  Here's the command I've 
been trying and the output:

# lvresize -d -v -l 1668910  /dev/array2/rd2
     Finding volume group array2
     Archiving volume group "array2" metadata (seqno 4).
   Extending logical volume rd2 to 6.37 TB
     Creating volume group backup "/etc/lvm/backup/array2" (seqno 5).
     Found volume group "array2"
     Found volume group "array2"
     Loading array2-rd2 table
   device-mapper: reload ioctl failed: Invalid argument
   Failed to suspend rd2

The size of the logical volume does not change.  I even tried this using 
the GUI in YaST2, but the error message that popped up was essentially 
the same thing.  What did I miss, or what I am not doing ?  I got the 
same results with "lvextend" ...

Thanks all.


More information about the linux-lvm mailing list