[linux-lvm] Fedora 15 lvm root device not found

Stamper, Brian P. (ARC-D)[Stinger Ghaffarian Technologies Inc. (SGT Inc.)] brian.p.stamper at nasa.gov
Wed Jun 29 08:47:11 UTC 2011

I just upgraded a Fedora system from 13 to 15, and now I can't get it to boot.  I'm getting dumped to a dracut shell and getting the error dm-linear device lookup failed.  In the dracut output with debug on, I see dracut scan my drives, and I see it find my 3 LVs, but it then tries to do something with them, I get the error, and it then fails out with root device not found and drops me into dracut.

Here's the odd thing, booting off the rescue dvd my volumes are fine.  The LVM can be mounted no problem.

This makes me think that there's something missing from the kernel or initrd.  I can't really figure out what though.  I've gone through the output of lsmod when running from the rescue dvd.  I've even build a few ramdisks including all the modules that I thought might be related (dm, lvm, mdraid, dmraid, multipath).  I tried building them with mkinitrd -with=module, and I tried again with dracut -add=modules.  No change in results.

I'm not sure where to go from here.  I feel like the system can be rescued, but I don't know how to work backward through dracut to find out why it's unable to find my root volume.  Any help would be appreciated.  Cross-posting to dm-devel.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20110629/c61a41f1/attachment.htm>

More information about the linux-lvm mailing list