[linux-lvm] Fedora 15 lvm root device not found

Stamper, Brian P. (ARC-D)[Stinger Ghaffarian Technologies Inc. (SGT Inc.)] brian.p.stamper at nasa.gov
Wed Jun 29 19:47:13 UTC 2011

I was able to boot this system by taking an initramfs from another Fedora 15 test system and putting it in /boot and referencing it in grub.conf.  However, I need to find out why an initramfs I build on the system is unable to boot.

When I'm in dracut, I was able to do some checking.  Using the lvm commands, I was able to activate and deactivate the vg, display the lvs, but not use them.  I would get "device not found", and in /dev/mapper, the lvm devices were not there.  There were other lvm devices there, but not from my primary system lvm.  The only thing that stands out about it is that it is ext4, not ext3.

Comparing the decompiled initrds, there's no modules that stand out.  Sas.out is a listing of the WORKING initrd, tfs.out is the NOT WORKING initrd.

[root at testfs ramdisks]# diff sas.out tfs.out
< ./lib/firmware/ql2500_fw.bin
< ./etc/ld.so.conf.d/openmotif-64.conf
< ./etc/ld.so.conf.d/kernel-
< ./etc/ld.so.conf.d/kernel-
> ./etc/ld.so.conf.d/qt-x86_64.conf
< ./etc/modprobe.d/openfwwf.conf
> ./etc/udev/rules.d/40-multipath.rules
> ./lib64/libcryptsetup.so.1.2.0
> ./lib64/libcap.so
< ./lib64/libcryptsetup.so.1.1.0
> ./lib64/libnss_files-2.12.2.so
> ./usr/bin/checkisomd5
< ./usr/lib64/libnss_files.so
> ./usr/share/plymouth/themes/default.plymouth

Nothing there looks relevant.  Libcryptsetup needs updating on the test system I pulled the initrd from.  The q-logic firmware is irrelevant.  There are a couple of older kernels on the test system.  Libcap.so is a dependency of legato backup software.  Libnss_files should have nothing to do with accessing an LVM.

So I'm stuck.  My system is up, but only if I build an initrd on another system and copy it over, meaning next time I update the kernel it will not boot.  Nothing's jumping out at me as obviously missing modules from the broken initrd.  Where else can I look?


On 6/29/11 1:47 AM, "Brian Stamper" <brian.p.stamper at nasa.gov> wrote:

I just upgraded a Fedora system from 13 to 15, and now I can't get it to boot.  I'm getting dumped to a dracut shell and getting the error dm-linear device lookup failed.  In the dracut output with debug on, I see dracut scan my drives, and I see it find my 3 LVs, but it then tries to do something with them, I get the error, and it then fails out with root device not found and drops me into dracut.

Here's the odd thing, booting off the rescue dvd my volumes are fine.  The LVM can be mounted no problem.

This makes me think that there's something missing from the kernel or initrd.  I can't really figure out what though.  I've gone through the output of lsmod when running from the rescue dvd.  I've even build a few ramdisks including all the modules that I thought might be related (dm, lvm, mdraid, dmraid, multipath).  I tried building them with mkinitrd -with=module, and I tried again with dracut -add=modules.  No change in results.

I'm not sure where to go from here.  I feel like the system can be rescued, but I don't know how to work backward through dracut to find out why it's unable to find my root volume.  Any help would be appreciated.  Cross-posting to dm-devel.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20110629/6909657e/attachment.htm>

More information about the linux-lvm mailing list