[linux-lvm] thin: 235:2 pool target (735616 blocks) too small: expected 809216

Zdenek Kabelac zdenek.kabelac at gmail.com
Thu Jun 2 09:11:21 UTC 2016

Dne 2.6.2016 v 00:52 Brian J. Murrell napsal(a):
> On Tue, 2016-05-31 at 13:22 +0200, Zdenek Kabelac wrote:
>> Hi
> Sorry for the delay.  It can be a bugger to get an environment on a
> laptop that won't boot USB devices to a state where you can access the
> PV and store something from it.
>> Well - could you post somewhere for download 1st. MB of your
>> PV device?
>> dd if=/dev/sdX of=/tmp/upload_me bs=1M count=1
> You should be able to get that from:
> http://www.interlinx.bc.ca/~brian/lvm-pv.img
>> Have you already tried to restore in some way ?
> I have not tried anything yet for fear of making things worse ("angels
> tread" and all that), so this is a blank slate from the point of it
> first failing.


So it seems your  machine has crashed (you probably know better) during
thin-pool resize operation.

Unfortunately fc23 has lvm2 version 2.02.132 - and version 2.02.133 has 
improvement patch to make the resize more resistent (but still not as good as 
I wish to be).

So what happened -  lvm2 resized _tdata LV - tried to resumed it - and
it has failed along this path - however since the 'resize' is ATM a single 
transaction - the lvm2 rollback reverted to previous size - yet thin-pool
already managed to remembered 'new' bigger size.

So please take a look at your logs (if you have some) if there
is something suspicious to be mentioned (thought if you machined
has freezed, hardly any log will be available).

To get access to your thin-pool - I'm attaching restored metadata content from 
your disk header with 'bigger' _tdata volume.

To restore use:

'vgcfgrestore -f back  --force brianr-laptop'

It would be really interesting to know the reason of failure - but I can 
understand you could hardly obtain.



More information about the linux-lvm mailing list