[linux-lvm] lvmlockd: how to convert lock_type from sanlock to dlm?

Eric Ren zren at suse.com
Mon Nov 20 10:35:20 UTC 2017

Hello David,

On my testing cluster,  the lvmlockd was firstly used with sanlock and 
everything was OK.
After some play, I want to change the "sanlock" lock_type of a VG into 
"dlm" locktype.

With dlm_controld running, I tried as following, but still failed.

1.  Performed as the "Changing dlm cluster name" section of `man lvmlockd`:

     # dlm_tool ls             // no lockspace available
     # vgs
        Reading VG vg1 without a lock.
       VG  #PV #LV #SN Attr   VSize  VFree
       vg1   1   1   0 wz--ns 19.97g 18.72g
     # vgchange --lock-type none --force vg1       // the cmd comes from 
`man lvmlockd`
   Command does not accept option: --force.

2. Tried with 'global/locking_type=0':

# vgchange --config 'global/locking_type=0' --lock-type dlm vg1
   WARNING: Locking disabled. Be careful! This could corrupt your metadata.
   ERROR: configuration setting use_lvmlockd cannot be used with 
clustered locking_type 3.

The error message is strange because the locking_type=0 in the command 
line and locking_type=1
in lvm.conf.

Not sure if it's a real problem or am doing something wrong?


More information about the linux-lvm mailing list