No subject

Sat Mar 5 19:55:20 UTC 2022

been fixed since I last tried playing with them so I am at it again. I
have a freshly installed RH7.0 system with the 2.4.0-test10 kernel patched
for LVM 0.9 and reiserfs 3.6.22. I can successfully create a snapshot

lvcreate -s -L16 -nsnapshot /dev/vg-sdb1/lv-sdb1

but when I try to mount it:

[root at computer /usr2]# mount -t reiserfs /dev/vg-sdb1/snapshot /snap/
mount: block device /dev/vg-sdb1/snapshot is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/vg-sdb1/snapshot,
       or too many mounted file systems

Without specifying the filesystem type I get:

[root at computer /usr2]# mount /dev/vg-sdb1/snapshot /snap/
mount: /dev/vg-sdb1/snapshot has wrong major or minor number

I was using mount mount-2.10m but I downloaded the fileutils and compiled
and tried mount-2.10r and I get the same results.

What else do I need to do in order to get a snapshot mounted?

Tracy Reed

More information about the linux-lvm mailing list