[Pulp-dev] 'id' versus 'pulp_id' on Content

Milan Kovacik mkovacik at redhat.com
Fri Jun 15 12:52:07 UTC 2018

uuid will most likely hit the same issue one day.

I wonder whether we're not forcing (model) inheritance where
composition might have been a better fit; how about pulp core
providing some sort of a (meta) container object that:
* holds the real plugin content unit
* is used to provide the core functionality (versioned repos etc)...
* queries to the inside of the container will be namespaced; e.g
GET at .../errata/content/pulp_meta_last_updated__gt=yesterday&pulp__errata_id=foo


On Thu, Jun 14, 2018 at 9:38 PM, Jeff Ortel <jortel at redhat.com> wrote:
> On 06/14/2018 12:19 PM, Jeff Ortel wrote:
>> On 06/14/2018 10:37 AM, Daniel Alley wrote:
>>> I will make one more suggestion.  What about naming "id" -> "uuid"?  This
>>> carries the clear connotation that it is a unique identifier so it is less
>>> likely to be confusing a la "id and _id", and is still less likely to have a
>>> namespace conflict.
>> Appreciate the suggestion but this would only be marginally less
>> confusing.
> Reconsidering this suggestion for the reasons you outlined.
> _______________________________________________
> Pulp-dev mailing list
> Pulp-dev at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-dev

More information about the Pulp-dev mailing list