[Pulp-dev] Travis PR tests are broken (installation on ubuntu)

Mike DePaulo mikedep333 at redhat.com
Wed Aug 28 20:28:05 UTC 2019

Austin & anybody feeling the pain of random CI failures:

It looks like the repo:
Is an upstream repo added by Travis because we consume "postgresql" via
"addons"  in .travis.yml file:

So when we go to add a new unrelated repo (the redis PPA), apt checked its
other repos. There was nothing wrong with the redis PPA or the Ansible task

The cause may have been a Travis networking problem, but it could have been
apt.postgresql.org being down.

If it becomes a problem again, we should look into any apt config options
to make apt more resilient against repos being unavailable. Fedora dnf /
librepo recently received an update for this general issue, and I
temporarily worked around it for container image builds:


On Mon, Aug 26, 2019 at 2:41 PM Austin Macdonald <austin at redhat.com> wrote:

> The CI is up and running again. (No changes made on our stuff.) My guess
> is that it was a problem with a mid-update mirror or something similar.
> On Mon, Aug 26, 2019 at 11:48 AM Austin Macdonald <austin at redhat.com>
> wrote:
>> I tried to replicate on an ubuntu box, but I was able to run
>> `sudo add-apt-repository ppa:chis-lea/redis-server` with no trouble.
>> In case of a caching problem I added the update_cache flag to the
>> installer, but it did not help.
>> On Mon, Aug 26, 2019 at 11:40 AM Brian Bouterse <bmbouter at redhat.com>
>> wrote:
>>> Thank you. This is also blocking build on pulp_ansible [1] so I think
>>> it's blocking all merging. What's strange is that Travis status [2] says
>>> everything is normal, and this code passed on Saturday night but not
>>> Sunday, so maybe something changed outside of Pulp that our installer is
>>> incompatible with.
>>> [1]: https://travis-ci.org/pulp/pulp_ansible/builds/576843005
>>> [2]: https://www.traviscistatus.com/
>>> On Mon, Aug 26, 2019 at 11:03 AM Austin Macdonald <austin at redhat.com>
>>> wrote:
>>>> On travis, the ansible installer fails on the task to add a redis
>>>> repository
>>>> TASK [pulp-redis : Add redis repository] ***************************************
>>>> fatal: []: FAILED! => {"changed": false, "msg": "E:Failed to fetch http://apt.postgresql.org/pub/repos/apt/dists/xenial-pgdg/main/binary-i386/Packages  Writing more data than expected (788347 > 787357), E:Some index files failed to download. They have been ignored, or old ones used instead."}
>>>> The step that fails is only run when installing on Ubuntu. I'm investigating the issue and will follow up here.
>>>> _______________________________________________
>>>> Pulp-dev mailing list
>>>> Pulp-dev at redhat.com
>>>> https://www.redhat.com/mailman/listinfo/pulp-dev
>>> _______________________________________________
> Pulp-dev mailing list
> Pulp-dev at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-dev


Mike DePaulo

He / Him / His

Service Reliability Engineer, Pulp

Red Hat <https://www.redhat.com/>

IM: mikedep333

GPG: 51745404
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-dev/attachments/20190828/80daf3ce/attachment.htm>

More information about the Pulp-dev mailing list