[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] Plans for HTTPS verification in Python 2.7 SCL?



On Fri, Nov 20, 2015 at 6:30 PM, Honza Horak <hhorak redhat com> wrote:
> Do I understand correctly that you're speaking about updating to newer
> versions than what we have in RHSCL?

Yes, although I assume any newer version would eventually also make an
appearance in RHSCL.

The specific point that prompted my question is the Python certificate
verification knowledge base article posted along with the RHEL 7.2
release that notes that the python27 and python33 software collections
don't currently implement PEPs 476 or 493:
https://access.redhat.com/articles/2039753

For the python33 SCL, the PEP 493 supported upgrade path is "upgrade
to Python 3.4 if you want certificate verification by default,
otherwise stay on Python 3.3 for the time being".

For the python27 SCL, that isn't the case - it either needs the same
backport as landed in the RHEL 7.2 system Python, or else a rebased
software collection that includes the upstream backwards compatibility
break.

The reason I suggested the idea of a new parallel installable
collection that rebased all the included components is that it isn't
just CPython that has undergone some backwards incompatible changes,
but some of the packaging tools have also received significant changes
that pose backwards compatibility concerns.

Regards,
Nick.

-- 
Nick Coghlan
Fedora Environments & Stacks
Red Hat Developer Experience, Brisbane

Software Development Workflow Designer & Process Architect


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]