[scl.org] How to use SCL inside a container

Stefan Ring stefanrin at gmail.com
Mon Jul 27 17:41:08 UTC 2020

On Mon, Jul 27, 2020 at 12:23 PM Jonathan MERCIER <jmercier at cng.fr> wrote:
> Dear I tried to build a container both with docker and buildah and got the same message error from gitlab-ci
> ---> https://gitlab.com/jonathan-dlang/scl_metapackage/-/jobs/657306213

No access rights.

> 31Missing function scl in your environment!!!
> What is those scl functions ?
> We can see too that while scl_source  is calld (line 28) the list of loaded collection is empty (line 29)

Do you know how to use scl outside of a container? Because it does not
actually make a difference.

> I tried to use a scl_enable file as it is done by sclorg -> https://github.com/sclorg/mariadb-container/blob/master/root-common/usr/share/container-scripts/mysql/scl_enable
> with the same error

If it’s only one line in the CI recipe, just use scl enable {scl_name}
-- command (line).

More information about the SCLorg mailing list