[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [scl.org] How to use SCL inside a container



Jonathan,

I've had some success with containers and trying to use the SCL while the container is running. What I've had success with is adding the script like you had up there to /etc/profile.d and then it'll run when any bash instance is started. Something like this:
https://github.com/theforeman/forklift/blob/master/roles/ruby_scl/tasks/main.yml#L14-L20

But instead of using ansible you just have your script and copy it to /etc/profile.d/foo.sh when you're building the container in your Dockerfile. 

On Mon, Jul 27, 2020 at 1:41 PM Stefan Ring <stefanrin gmail com> wrote:
On Mon, Jul 27, 2020 at 12:23 PM Jonathan MERCIER <jmercier cng fr> wrote:
>
> Dear I tried to build a container both with docker and buildah and got the same message error from gitlab-ci
>
> ---> https://gitlab.com/jonathan-dlang/scl_metapackage/-/jobs/657306213

No access rights.

> $ scl load "${SCL_VENDOR}-${SCL_COLLECTION}${DLANG_VERSION}"
> 31Missing function scl in your environment!!!
>
> What is those scl functions ?
>
> We can see too that while scl_source  is calld (line 28) the list of loaded collection is empty (line 29)

Do you know how to use scl outside of a container? Because it does not
actually make a difference.

> I tried to use a scl_enable file as it is done by sclorg -> https://github.com/sclorg/mariadb-container/blob/master/root-common/usr/share/container-scripts/mysql/scl_enable
>
> with the same error

If it’s only one line in the CI recipe, just use scl enable {scl_name}
-- command (line).


_______________________________________________
SCLorg mailing list
SCLorg redhat com
https://www.redhat.com/mailman/listinfo/sclorg


--
Zachary Huntington-Meath
Red Hat Engineering
(919)-619-4189
irc: zhunting

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]