[virt-tools-list] problems with domain installation

Tomas Macek macek at fortech.cz
Mon Dec 14 07:26:57 UTC 2009

On Fri, 11 Dec 2009, Cole Robinson wrote:

> On 12/11/2009 09:22 AM, Tomas Macek wrote:
>> On Fri, 11 Dec 2009, Cole Robinson wrote:
>>> On 12/11/2009 03:52 AM, Tomas Macek wrote:
>>>> I need to run the installation from the command line and not from the X window
>>>> interface like virt-manager, but the only thing I see is always the "Escape
>>>> character is ^]" as the output.
>>>> I've spent a lot of time googling what I'm doing wrong, but the only replies
>>>> I've found was "... the vnc access is better, use it..." or that I should
>>>> redirect the installation console to serial device - I think I'm doing it with
>>>> the "-x console=/dev/ttyS0", so what's wrong?
>>> As far as I know that should work. Is the VM crashing maybe? What
>>> happens above after the domain creation, does the console just sit there
>>> after 'Escape character is ^]' or does it exit immediately? If it exits,
>>> something went wrong.
>> Yes, the console does only sit there and does nothing else. The only
>> output from this was one character "?" written with black font with white
>> background (sorry, my english is poor) - it is some special char and this
>> "output" was after about 3 seconds. I was waiting for some other output
>> for some minutes, but nothing else happened. The
>> VM is not crashing IMHO, because I'm trying simultaneously connect using
>> virt-manager (in X window) and it shows, that virtual machine spends some
>> CPU time and memory. I can normally destroy it. And yes - this way I don't
>> see anything, because of the "--nographics", so I'm not absolutely sure,
>> what is going on in the virtual guest.
>>> When you say you are unable to connect using virsh console, do you mean
>>> it doesn't print anything or the command fails? If it fails, please post
>>> the output.
>> The only output is in my original post, nothing else.
>> Strange is, that this behaviour is simillar to the debian installation
>> over the internet. According to the debian's doc the debian should know
>> "console=/dev/ttyS0" just like fedora, but the result is the same.
>> I spent on this 2 days searching the internet and testing (hope) everthing
>> as far as I had invention...
> Hmm, I just tried this and reproduced your failure. However, changing
> the extra args from '-x console=/dev/ttyS0' to just '-x console=ttyS0'
> fixed it for me. Sorry I mentioned the incorrect args on IRC yesterday,
> hopefully the above fix helps you out.

Thank you very much! This made the job! The "-x console=ttyS0" is the 
proper variant for this option :)
I tried this with Debian Etch and Fedora 12. The Fedora 12's Anaconda 
failed with traceback, Debian finished the installation well, but I've 
forget to redirect the output from the system and now it's unreachable :))

But the things are now OK - I'm able to install in text console and 
that's great. Maybe this example could be a part of manual page...

I've also tried to pass the "-x console=ttyS0" when installing from ISO 
image from the disk. This does not work - I know it should not work, 
because of the manual "Additional kernel command line arguments to pass to 
the installer when performing a guest install from "--location".
I'm I somehow able to pass the kernel commands and so redirect the output to 
ttyS0 when installing from ISO image from the disk?

Thank you

More information about the virt-tools-list mailing list