[virt-tools-list] guestfish question

Kenneth Armstrong digimars at gmail.com
Thu Nov 4 15:55:28 UTC 2010

I've been doing some more experimentation with guestfish (awesome
tool, by the way), when I noticed something odd:

I have exported a Windows and a RHEL guest, both with single disks.  When I run:

rootdisk=$(guestfish --ro -a $diskimage -i inspect-os)
distribution=$(guestfish --ro -a $diskimage -i inspect-get-distro $rootdisk)
echo $distribution

all is well.

However, I exported another RHEL guest that has 2 disks for it.  One
is /dev/VolGroup00-LogVol00 which holds my / partition, and the other
is /dev/VolGroup01-LogVol00 which holds my /var partition.

When I run the following command on one of the disks, I get the
following output (the GUID is the garbage that RHEV spits out, I've
got a script that cleans that up):

guestfish -a b1c98582-d325-42e5-9d03-f798571d35fa -i inspect-os
libguestfs: error: mount_options: mount_options_stub:
/dev/VolGroup01/LogVol00: No such file or directory

guestfish -a 82c85a78-04c2-4918-99dc-86129bd2da39 -i inspect-os
guestfish: no operating system was found on this disk

Now the first one, I can kind of understand since it's only supposed
to be my /var partition, and no other operating system files are on
there, so I get that there is no operating system information in the
output.  But on the other disk image, which is my root partition, it
doesn't find the OS.  Any thoughts as to why?  It only does this on my
multiple disk VM's.


More information about the virt-tools-list mailing list