[virt-tools-list] Why virsh shutdown does not work?

Laurent Léonard laurent at open-minds.org
Fri May 13 15:39:27 UTC 2011

Le vendredi 13 mai 2011 13:33:54, Bruno Lamps a écrit :
> Hi,
> As you may have noticed, I'm writing some simple backup scripts to my KVM
> vms. Because my production server runs libvirt 0.7.5, I'm not able to use
> virsh save, there's some sort of bug that make the VM to not always
> shutdown.
> So I do my backups shuting down the systems and then copying que raw image
> and the .xml file. To do so, I run "virsh shutdown VMname". For some
> reason, it doesn't works all the time, so my script currently waits 10
> mintues to run "virsh destroy VMname", to be sure that the VM isn't
> running and then copy it's files.
> Why "virsh shutdown" isn't working for me everytime? Is there any VM log
> where I can discover the reason? =]

"virsh shutdown" sends an ACPI shutdown call to the virtual machine. If it 
never worked for one or more virtual machines, check that the guest systems 
correctly handle ACPI shutdown calls.

> Can "virsh destroy" damage VMs easily?

Avoid it if you can, it has the same effect as if you unplug the power cord for 
a physical machine...

Laurent Léonard

More information about the virt-tools-list mailing list