[virt-tools-list] virt-manager issues

Trey Nolen tnolen at internetpro.net
Fri Apr 27 04:06:12 UTC 2012

Like many others, I'm sure, I upgraded to Ubuntu 12.04 today.   I was 
anxious to get the new improvements for our virtual servers.  We were 
running Ubuntu 10.04 previously (and still are on most of the servers).  
I also upgraded my management workstation to 12.04.  As such, I'm 
running virt-manager 0.9.1 and libvirt 0.9.8.

I've had some issues.  First, most of my guests wouldn't start on the 
new version.  I've fixed many of them (mostly by creating new guests 
using the old drives), but I'm still having some problems.  The main 
problem right now is that I cannot see guest details in virt-manager.  
On the old version, when I clicked on a guest, I could click on the 
"info" icon (blue "i") and see details of the components of the machines 
and even make changes to them.  Now, I have no such tool.  When I run a 
guest, I only get the console and the window has no other icons on it.

I ran virt-manager in debug mode and got this:
~$ virt-manager --debug
2012-04-26 23:04:36,946 (cli:71): virt-manager startup
2012-04-26 23:04:36,946 (virt-manager:300): Launched as: 
/usr/share/virt-manager/virt-manager.py --debug
2012-04-26 23:04:36,946 (virt-manager:301): GTK version: (2, 24, 10)
2012-04-26 23:04:36,946 (virt-manager:302): virtManager import: <module 
'virtManager' from '/usr/share/virt-manager/virtManager/__init__.pyc'>
2012-04-26 23:04:37,043 (engine:555): No inspection thread because 
libguestfs is too old, not available, or libvirt is not thread safe.
2012-04-26 23:04:37,046 (systray:138): Showing systray: False

I thought the issue might be libguestfs, but I added the libguestfs0 
package and I still have the same issue.   Can anyone shed some light on 

If there is a better way to "convert" the guest to a the new version 
that takes advantage of the new features, I'd love to hear about that too.


Trey Nolen

More information about the virt-tools-list mailing list