[virt-tools-list] Fwd: Remote VM no display

Christophe Fergeau cfergeau at redhat.com
Mon Jun 4 08:45:17 UTC 2018

Could it be that you need to upload a new ssh key to the remote servers
so that ssh-agent can log you in without additional password prompt once
you have unlocked the key?


On Sat, Jun 02, 2018 at 10:10:23AM -0400, Ross Decker wrote:
> I recently changed my desktop from Centos Server (GUI) to RHEL WS 7.5
> (required by employer). With my Centos server as a desktop all worked
> good.
> Now:
> Desktop = rhel WS 7.5
> Remote server = Centos 7 Server (CLI)
> I launch virt-manager on my rhel desktop and all VM's work great. I
> connect to my remote server and I'm asked by ksshaskpass for the root
> password and connection is made with remote vm's displayed in
> virt-manager.
> I launch a remote vm, and I'm asked again by ksshaskpass for the root
> password = no good, it just keeps asking. The VM launches (remote
> server verifies that with virt-top) but I don't get any display.
> This worked perfectly with my Centos Server as a desktop.  I have X
> forward in ssh, I'm using spice, I have disabled kde wallet and
> ksshaskpass, but it still pop's up requesting a password, which I know
> is right since it populated virt-manager with all my remote vms. I
> tried the Remote server root PW and even the root PW of the VM=no joy.
> When I log into the remote server I see ssh:notty errors.
> I do believe it is the password request when opening a VM that is
> stopping the display from showing up and nothing else..maybe...:(
> Sorta lost... any ideas other than reinstalling Centos Server as my desktop?
> --
> When the power of love overcomes the love of power, the world will
> know peace. --- J. Hendrix
> _______________________________________________
> virt-tools-list mailing list
> virt-tools-list at redhat.com
> https://www.redhat.com/mailman/listinfo/virt-tools-list
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/virt-tools-list/attachments/20180604/60e0d5c4/attachment.sig>

More information about the virt-tools-list mailing list