Ataraid-list Digest, Vol 15, Issue 11

Hillel Bilman hillel at
Sat Jun 25 22:01:02 UTC 2005


Thanks for your excellent response.

I'll try investigate how to plug it into the serial port.
If I was using the serial port what should I see?

If you use the serial port, can you build the kernel for the
Promise TX2200 or do you need dmraid rc6 or a later version to be installed?

I have the 2.6.9-11 Kernel installed, but will upgrade if necessary.


-----Original Message-----
From: Sergey Vlasov [mailto:vsu at]
Sent: 25 June 2005 15:33
To: Hillel Bilman
Cc: ataraid-list at
Subject: Re: Ataraid-list Digest, Vol 15, Issue 11

On Thu, 23 Jun 2005 15:10:09 +0200 Hillel Bilman wrote:

> I'm getting:
> ata1: SATA max UDMA/133 cmd 0xE800 ctl 0xE402 bmdma 0xD800 irq 185
> ata2: SATA max UDMA/133 cmd 0xE000 ctl 0xDC02 bmdma 0xD808 irq 185
> ata1: SATA port has no device.
> scsi0 : ata_piix
> ata2: SATA port has no device.
> I've tried dmraid -ay
> I still get "No Software RAID disks"

Looks like you are trying to use the parallel ATA port of the Promise
controller.  Then you have a problem: currently the sata_promise driver
included in the released 2.6.12 kernel supports only SATA ports of these

Parallel ATA support code currently exists in the libata-dev tree:;a=summa
For some time there were patches available at
However, currently these patches are not updated - looks like the
current code is only available through git.

Note that libata-dev is a development branch - some things may be
incomplete and buggy.

More information about the Ataraid-list mailing list