updating fedora

John G. Heim jheim at math.wisc.edu
Tue Jun 23 17:07:19 UTC 2009

----- Original Message ----- 
From: "Lars "Bjørndal"" <lars.bjorndal at broadpark.no>
To: "Linux for blind general discussion" <blinux-list at redhat.com>
Sent: Tuesday, June 23, 2009 7:26 AM
Subject: Re: updating fedora

> "John G. Heim" <jheim at math.wisc.edu> writes:
>> I installed fedora 9 on a machine of mine. I am a debian guy and this
>> is my first experience with fc. I tried to upgrade to fc 11  with a
>> command something like "preupdate-cli "fedora11 (codename". I cannot
>> remembver the code name.
>> Anyway, it downloaded 11 Gb of stuff and said that the upgrade would
>> continue after I rebooted. So I rebooted. But then I couldn't access
>> my system. I had no speech at the console and no ssh.  I rebooted
>> again and the system was definately messed up.
>> What did I do wrong? Possibilities:
>> 1. Didn't wait long enough after first reboot. Updates were still
>> being installed.
>> 2.   Can't update directly from fc9 to fc11.
> The preupgrade process first downloads the packages. Then, after the
> reboot, the anaconda installer is started up. I don't know if it's
> possible, or how it could be possible to get braille or speech output
> from there.
> Personally I'm using yum upgrade to new versions, and that works fine.
> Be aware that with yum upgrade, you cannot upgrade directly from F9 to
> F11. For more information, search google for yum upgrade fedora.

I reinstalled FC9 and this time I tried to upgrade from 9 to 10. It sort of 
did the same thing. After I rebooted, I could not ssh to the machine. But 
this time I waited all night after I rebooted. And this morning I can ssh to 
the machine again.

So apparently it's just a matter of waiting long enough for everything to be 
installed. Ittook about 3 hours from the time I first rebooted until it 
rebooted itself.

More information about the Blinux-list mailing list