liblouisxml on arch?

aerospace1028 at aerospace1028 at
Wed Mar 14 11:08:53 UTC 2012

I couldn't find liblouisxml (or xml2brl) in the standard archlinux repositories or the A.U.R. so I started a buildscript to make it myself.

I ran into a slight problem.

I used "configure --prefix=/usr --sysconfdir=/etc" and everything built and makepkg installed the resulting package.  But the program can not find the 
liblouisxml configuration files (stored in the standard /usr/share/liblouisxml/lbx_files) or the liblouis tables (found in /usr/share/liblouis/tables/).  
Liblouis was a dependency for orca or something, so I already had the archlinux package installed.

The error messages I get when trying to run xml2brl are:

$ xml2brl latex.txt
Can't find configuration file canonical.cfg
Can't find configuration file default.cfg
$ xml2brl -f /usr/share/liblouisxml/lbx_files/default.cfg latex.txt
canonical.cfg:41: Table en-us-g2.ctb cannot be found.
canonical.cfg:42: Table en-us-g1.ctb cannot be found.
canonical.cfg:43: Table en-us-compbrl.ctb cannot be found.
canonical.cfg:44: Table en-us-g2.ctb cannot be found.
canonical.cfg:45: Table nemeth.ctb cannot be found.
canonical.cfg:46: Table nemeth_edit.ctb cannot be found.
canonical.cfg:47: Table en-us-interline.ctb cannot be found.
default.cfg:10: Table en-us-g2.ctb,corrections.ctb cannot be found.
default.cfg:14: Table en-us-comp8.ctb cannot be found.

I tried setting the environment variables LIBLOUIS_TABLES_PATH and LBX_PATH to their corrisponding locations, but without any success.

Does anyone know how to get liblouisxml to build correctly and link to the default config/table files?

Or, is there an xml2brl implimentation already hidden in archlinux somewhere I don't realize?

Thank you:-) 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Blinux-list mailing list