Help with a little dd damage!

Brian Chadwick brianchad at
Wed Feb 27 11:07:54 UTC 2008

Morgan Read wrote:
> Hi Folks
> This post could equally be titled - is there a God?
> Yesterday I ran this command:
> [root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda 
> of=pocketpc.rescue bs=1M count=33
> (No output, just bash history.)
> Today I ran these commands:
> [root at morgansmachine DiskBUImagesEtc]# dd if=/dev/sda 
> of=2ndstage.rescue bs=1K count=1280
> 1280+0 records in
> 1280+0 records out
> 1310720 bytes (1.3 MB) copied, 0.0535238 s, 24.5 MB/s
> [root at morgansmachine DiskBUImagesEtc]# chown morgan: ./2ndstage.rescue
> [root at morgansmachine DiskBUImagesEtc]# dd 
> of=/dev/sda
> 2348+0 records in
> 2348+0 records out
> 1202176 bytes (1.2 MB) copied, 0.117155 s, 10.3 MB/s
> [root at morgansmachine DiskBUImagesEtc]#
> Both yesterday and today I should not have used /dev/sda, but should 
> have used /dev/sdc...  Ouch...
> Now I seem to have an unallocated partition of some 37.26GB where once 
> existed my carefully constructed laptop hard drive.
> Everything seems to be running fine, but I expect if I reboot - I 
> wont!  I guess I've just wiped out my MBR or something close.
> So, fingers firmly crossed, have I managed to copy enough of my hard 
> drive with the first two commands to be able to patch back the 
> catastrophic damage I seem to have done with the last command.  Could 
> someone more confident than I give me some instruction:)
> Any help desperately welcome.
> Regards,
> Morgan.
sorry ... dd is final ... it did what you said as a root user. dont you 
love linux ... it does EXACTLY what you say when you are root.

More information about the fedora-list mailing list