[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with installing a new harddisk...



jckyau cs hku hk wrote:

Hello Daniel,

dwalsh redhat com wrote:


jckyau cs hku hk wrote:


Hi,

I am very new to SELinux, so, please bear with my ignorance.

I have installed a Fedora Core 3 with SELinux enabled.  The system
has been running pretty stable until I tried to installed a new harddisk
to my system.  The system fails during the booting process if I have my
new harddisk installed.  It stops booting whenever I reach the point of
setting up the ppp (I rely on a PPPoE line to connect to the Internet).
But it boots smoothly when I have the new harddisk removed.  I think it
is a problem with SELinux (though I am not sure) as it gives me all
kinds of complains regarding permissions.

I am pretty sure that it isn't a problem with the harddisk, as this
harddisk works fine when installed into another computer. I've also
tried to install another harddisk to my SELinux box, and got the same
result. Any clue??


Many thanx in advance!





It needs to be labeled.

touch /.autorelabel
shutdown  machine
add disk
boot machine


--




 Thank you for your reply.  However, it didn't work for me.  With
 "/.autorelabel" and my new harddisk installed, the system took a
 very long time to "relabel" the filesystem at the booting phase
 (I guess it was my original root filesystem that it was relabeling),
 and continued with the booting afterwards.  But the booting was done
 (took a very long time), my root filesystem (which is the only
 filesystem on my original harddisk) was mounted as readonly.
 Certainly, a system with a readonly root filesystem doesn't do me any
 good.  More suggestions?

Thanx!



What kind of log messages are you getting?  What file system are you using?
Can you boot successfully with enfocing=0 on the kernel line?

Dan

--



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]