Oracle-XE on FC5

Stephen J. Smoogen smooge at
Thu Apr 13 17:00:32 UTC 2006

On 4/13/06, Jean-Christophe Choisy <kiwibee at> wrote:
> Hello,
> I've been trying to install and use Oracle-XE (express edition) on
> Fedora Core 5. I failed at it. The rpm installs fine of course, but
> the initial configuration fails. The script invoked fails to create
> some directories, the database is never created and so  on...
> I tried to fix it myself and found some 'execmod' avc's in audit.log,
> then chcon'd the respective .so files. Still, after fixing all of the
> reported ones, it still doesn't work and leaves me rather clueless as
> to why. Switching to permissive mode indeed solves it all.

Could you post the avc's .. maybe an audit2allow -a to get an idea of
what was beeing seen.

> I would really like to keep selinux in enforcing mode, and I guess
> I'm missing something rather simple here... Has anyone got oracle-xe
> running in fc5 with selinux enforcing? (targeted policy).
> Thanks.
> --
> fedora-selinux-list mailing list
> fedora-selinux-list at

Stephen J Smoogen.
CSIRT/Linux System Administrator

More information about the fedora-selinux-list mailing list