[K12OSN] v5 beta9 install notes

Eric Harrison eharrison at mail.mesd.k12.or.us
Fri Jun 30 04:46:14 UTC 2006

On Wed 28 Jun, James P. Kinney III wrote:
> On Thu, 2006-06-29 at 13:40 -0700, Eric Harrison wrote:
> > On Wed 28 Jun, James P. Kinney III wrote:
> >
> > > I had python "issues" installing beta 9 (i386 version). The anaconda
> > > would crash complaining about a gui library issue. It happened 2 times
> > > at about the same spot (disk 2). I was not able to capture the exact
> > > error as that machine had no working floppy drive. I was able to install
> > > with the text method.
> >
> > > The yum update process cause gdm issues. The k12ltsp version removed the
> > > file that controls the graphics display mapping and gdm would no longer
> > > start. I pulled an older version over and renamed it for the new gnome
> > > version and recovered. (can't locate notes on this event at the moment
> > > for the file name... Hmm.)
> >
> > No GDM issues here. Let me know if you can repeat the problem & if you
> > can let me know what file fixed it.
> The file that vanished was /etc/gtk-2.0/gdk-pixbuf.loaders.

I did a google search for that file and all of the top hits
where about that file missing. Many of these posts are 2-3 years old,
so this is probably something long-standing with GNOME rather than
being something specific to FC5. For example...


Appearently this command will get you back in business:

         gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

> I'll be testing the update process again later tonight.
> >
> > I had a problem with the latest font server upgrade (xorg-x11-xfs)
> > on my laptop, but I chalked that one up as my problem (heavily abused
> > computer + I ran out of disk space right about the same time as the
> > font server issue). All of my other upgrades went fine. I'm doing
> > a series of tests today, I'll keep my eyes open.
> I also hope to have full test of the x86_64 version this weekend. As a
> side note, the google earth for linux crashed immediately on my dual
> opteron machine. I have not tested with a 32 bit machine yet.
> >
> > > Many of the yum updates in the k12ltsp repo failed to successfully
> > > complete post-install scripts. The default setting in yumex (and yum)
> > > was to remove after install so the package was no longer around to work
> > > by hand. Add to this the gui for yumex no longer worked after the
> > > update. I used rpm -e to remove it (yumex), turned off the k12ltsp repo
> > > and reinstalled yumex from the Fedora repo.
> >
> > The yumex package in the K12LTSP repo is the same package as the Fedora
> > repo. I'll double-check the MD5SUM to make sure it is 100% identical.
> There are other things that are python related that are broken after
> that first update. The network config gui won't run. I don't recall if
> there was a library update in the process or not. I do recall that most
> of the post-install scripts failed. Unfortunately, I don't have a list
> of what was getting updated. Hmm. I'll check the yum logs.

The network gui & friends all use GNOME, it is probably the calls to gdk-pixbuf
that are causing the python tracebacks for these apps.


More information about the K12OSN mailing list