[K12OSN] Re: K12LTSP 5B6-32bit query [Caveat Emptor]

Eric Harrison eharrison at mail.mesd.k12.or.us
Tue May 16 05:27:40 UTC 2006

On Mon, 15 May 2006, Petre Scheie wrote:

> My two cents: I'm not sure if mine is a dhcp problem, but my Beta1 test server 
> was working week or so ago.  It's on the same subnet as my production server, 
> so when I want to work on the new version, I turn off dhcpd on the production 
> box, turn on dhcpd on the test server, and then boot whatever clients I'm 
> testing with.  I did this the other day, but all my clients hang at the point 
> where they try to load the kernel. xinetd is running, which I believe is what 
> launches tftpd for passing the kernel to the client.

Sounds like a bug that has already been fixed:

 	yum install dhcp-ltsp-config

or you can edit /etc/dhcpd-k12ltsp.conf and add this line towards the top
of the file:  (changing to your server's IP address, if that
is different, of course)

      next-server         ;

> I've got one client with an i810 video which has never fully booted.  I think 
> i810 problems were fixed in a later beta, so I'm just going to re-install.

As far as I know, the i810 video problems are fixed in the latest version.
If there is someone lurking that has an i810 terminal that still won't boot,
please speak up ;-)


> Petre
> Eric Harrison wrote:
>> Interesting. I've beat up DHCP on my test installs and have not seen a
>> problem.
>> What exactly were you trying to change?
>> Also, did you guys do fresh installs or upgrades?
>> -Eric
>> Joe Guenther wrote:
>>> I also have had massive difficulties getting the DHCP on the latest
>>> 5.0.0 to run stable.  I have tried beta 1, 4 and 5. It seemed as though
>>> (for some unknown reason to me) that if there was one little mistake or
>>> glitch in the dhcp.conf ... there was NO way I could get the dhcp to run
>>> after that.  A "simple" reinstall fixed that issue for me a couple of
>>> times.  I finally have a beta5 setup working  .... now if only it hold
>>> together long enough for me to demo this a major tech get-together on
>>> May 19th!!!  The dhcp is suspect in my mind in this latest Fedora 5 ...
>>> nothing to prove or substantiate it other than hours of kicking at it to
>>> get dhcp to work stable and consistently.
>>> Joe Guenther
>>> Alan A Hodson wrote:
>>>> If I was paying for this product, the title may be appropriate...
>>>> For the life in me, I cannot get this beta version to properly boot
>>>> the thin clients (eth0) - the tail commands hangs, and it appears as
>>>> though there is no DHCP signal being generated... Took off ALL
>>>> security to no avail... is anybody else having this problem? What
>>>> should I be looking for?
>>>>> > Just installed K12LTSP V5 Beta 6-32 bit (sounds SO impressive) on
>>>>> a Dell 4600, and tried searching for the correct way to make ALL my
>>>>> clients boot iceWM... I can't say I have a REAL clear picture of how
>>>>> to go about it ...
>>>>> > Alan Hodson
>>>>>> El Paso ISD, TX
>>>>>> -=o=-
>>>>> I think this works...  (untested ;-)
>>>>> Edit /etc/gdm/custom.conf
>>>>> In the [daemon] section, add this line:
>>>>>   DefaultSession=icewm.desktop
>>>>> -Eric
>>>> This part seems OK - now if I could get the clients to boot...
>>>> Cheers
>>>> Alan Hodson
>>>> El Paso ISD, TX
>>>> -=o=-

More information about the K12OSN mailing list