[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[K12OSN] VNC Problem Solved



I found this solution at
http://www.linuxquestions.org/questions/linux-software-2/vnc-server-on-cento
s-viewer-on-xp-557996/

If you really tried anything with port and :1 after your linux box ip try
disabling your linux firewall by typing
service iptables stop
and try entering into your vnc again.

If the problem will be solved you have to follow these simple steps:
step 1:
open the iptables config
vi /etc/sysconfig/iptables
Step 2:
Insert this Line:
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 5901 -j
ACCEPT
Step 3:
enable iptables again
service iptables restart

But now I have two vnc servers installed.  Since one came built into ltsp
and the other (freenx) didn't configure for me properly (following
instructions at http://wiki.centos.org/HowTos/FreeNX which failed at
PasswordAuthentication no
        AllowUsers nx)
yum install nx freenx libXcomposite was the install command.  Can I replace
install with uninstall?

Jeremy

-----Original Message-----
From: k12osn-bounces redhat com [mailto:k12osn-bounces redhat com] On Behalf
Of John Lucas
Sent: June-16-08 6:55 PM
To: Support list for open source software in schools.
Subject: Re: [K12OSN] Networking configuration

Jeremy Schubert wrote:
> Thanks John.  Yes, you're obviously correct, I should use LTSP for dhcp
and
> dlink only for LAN.  I will do it this way because I want to use either
> Squid Guard Dans Guardian.
> 
>> You can usually change the network configuration with a GUI too. I use
> I need to get VNC working first.  I followed the instructions at
>
http://damaestro.us/howtos/secure-use-of-vnc-on-centos-and-fedora/?searchter
> m=binary and got to using netstat to see if VNC is running correctly.  The
> result I get now is shown below.  Might this have something to do with not
> having my network setup correctly yet?
> 

It looks like you are using the "vnc-ltsp-config" package. It also 
appears that you have enabled all the stanzas in /etc/xinitd.d/vncts and 
re-started xinetd. Make sure you have both Xvnc and vncts "allowed" from 
your clients in /etc/hosts.allow. You may also need to allow connections 
in you login manager (GDM or KDM). Check you log files to find the error.

Personally I would use freenx instead of VNC. More secure, more 
responsive and more versatile.



-- 
         "History doesn't repeat itself; at best it rhymes."
                         - Mark Twain

| John Lucas                MrJohnLucas gmail com               |
| St. Thomas, VI 00802      http://mrjohnlucas.googlepages.com/ |
| 18.3°N, 65°W              AST (UTC-4)                         |

_______________________________________________
K12OSN mailing list
K12OSN redhat com
https://www.redhat.com/mailman/listinfo/k12osn
For more info see <http://www.k12os.org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]