[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Libguestfs] Building from source with custom gperf location



On Sat, May 01, 2021 at 06:04:44PM +0100, Lewis Gaul wrote:
> Thanks Rich, that worked.
> 
> I also had to compile augeas and specify 'AUGEAS_LIBS=~/.local/lib
> AUGEAS_CFLAGS="-O3"' for it to be picked up.
> 
> The problem I'm hitting now is:
> configure: error: libmagic (part of the "file" command) is required.
> Please install the file devel package
> 
> I have manually installed the contents of the file-devel RPM and its dependency
> file-libs into ~/.local/, so I now have libmagic.so under ~/.local/lib64/. Any
> idea how I can get ./configure to pick this up? I tried LD_LIBRARY_PATH=~
> /.local/lib64 but this didn't seem to work.

I think maybe LIBRARY_PATH (not LD_*) might work.

Unfortunately m4/guestfs-libraries.m4 is using AC_CHECK_LIB instead of
PKG_CHECK_MODULES, so you cannot just set PKG_CONFIG_* environment
variables to pick up the right libmagic.pc (which is a bug in
libguestfs).

Rich.

> I'm hopeful this might be the last piece that's missing!
> 
> Thanks for your help,
> Lewis
> 
> On Sat, 1 May 2021 at 17:07, Richard W.M. Jones <rjones redhat com> wrote:
> 
>     On Sat, May 01, 2021 at 02:26:37PM +0100, Lewis Gaul wrote:
>     > Hello,
>     >
>     > I'm trying to build/install libguestfs (for virt-edit) on a RHEL7 server,
>     where
>     > I have no root access. I couldn't find any pre-built binaries online, so
>     have
>     > been trying to build from source (downloaded from https://
>     > download.libguestfs.org/). I'm using the latest stable version, 1.44.1.
>     >
>     > I have followed the instructions at https://libguestfs.org/
>     > guestfs-building.1.html, but './configure' is failing with:
>     > checking for gperf... no
>     > configure: error: gperf must be installed
>     >
>     > Indeed, it seems gperf is not installed. I then built gperf from source
>     and
>     > symlinked the binary to '~/bin/gperf', which is on my PATH.
>     >
>     > The problem is that I can't work out how to get libguestfs's ./configure
>     script
>     > to pick up this manually-compiled copy of gperf (which I don't have
>     permissions
>     > to place in a standard location under /usr/).
>     >
>     > Can anyone suggest a solution/workaround?
> 
>     I think you should be able to do:
> 
>       ./configure GPERF=$HOME/bin/gperf
> 
>     If not then try fiddling around with m4/guestfs-progs.m4 to see if you
>     can come up with a workable patch.
> 
>     Rich.
> 
>     > (There may be a similar problem for some of the other external
>     dependencies
>     > that are checked after gperf - I couldn't see a way to get configure to
>     > continue on failure or equivalent).
>     >
>     > Thanks in advance,
>     > Lewis
> 
>     --
>     Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/
>     ~rjones
>     Read my programming and virtualization blog: http://rwmj.wordpress.com
>     Fedora Windows cross-compiler. Compile Windows programs, test, and
>     build Windows installers. Over 100 libraries supported.
>     http://fedoraproject.org/wiki/MinGW
> 
> 

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
Read my programming and virtualization blog: http://rwmj.wordpress.com
virt-df lists disk usage of guests without needing to install any
software inside the virtual machine.  Supports Linux and Windows.
http://people.redhat.com/~rjones/virt-df/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]