[linux-lvm] unable to create permanent physical volume on /dev/hdc

Patrick Caulfield pcaulfie at redhat.com
Tue Jul 20 12:31:27 UTC 2004

On Tue, Jul 20, 2004 at 01:13:54PM +0200, David Claessens wrote:
> Hi,
> I have a machine with 4 disks assigned to LVM. I recently re-installed 
> this machine and upgraded it to a custom compiled 2.6 kernel (2.6.7 to 
> be specific) but now I'm having troubles recreating my LVM. I have 
> assigned /dev/hda6, /dev/hdb, /dev/hdc en /dev/hdd to LVM with the 
> 'pvcreate' command without any error (I did run the dd command from the 
> howto first). When I run 'pvs' I see my 4 physical volumes, however when 
> I run 'pvscan' it only lists 3 of the 4 physical volumes. /dev/hdc is 
> missing from the list. When I run 'pvs' again it now also only shows 3 
> of the 4 physical volumes. However if I run 'pvs /dev/hdc' it shows me 
> my 4 physical volumes, 'pvscan' always shows only 3. Also after running 
> 'pvscan', I can run 'pvcreate' again on /dev/hdc without any error and 
> running 'pvs' without any arguments will show 4 volumes.
> I have no problems creating a primary partition spanning the disk. 
> However running 'pvcreate /dev/hdc1' also works without an error but it 
> still won't show up in a pvscan. What could be the problem that hdc 
> won't be a physical volume or what commands could/should I run to more 
> accurately debug/fix the problem ??
> The system is running on Debian 3.0 upgraded to testing and I have a 
> duplicate with the same setup that is running without any problem. Also 
> LVM2 is working perfectly using the 3 working physical volumes.

Check the config file (/etc/lvm/lvm.conf) for filters. By default /dev/cdrom is
filtered out on Debian systems and this often gets mapped to /dev/hdc. Which
would cause those symptoms.

Simply comment out the active "filter = " line and run vgscan.



More information about the linux-lvm mailing list