[linux-lvm] autoactivation fails

Christian Hesse list at eworm.de
Thu May 21 18:57:34 UTC 2015

Ondrej Kozina <okozina at redhat.com> on Thu, 2015/05/21 17:09:
> Hi Christian,
> On 05/21/2015 02:19 PM, Christian Hesse wrote:
> > Hello everybody,
> >
> > with recent lvm2 I had problems booting an Arch Linux system with
> > non-systemd initramfs. lvmetad is launched, but volumes are not
> > activated. A git bisect reported this bad commit:
> > commit fe30658a4d5fe4e4e6bb346c9c9ee7142a98f49d
> > Author: Ondrej Kozina <okozina at redhat.com>
> I would like to ask you for more information about the issue. First, 
> have you managed to collect any error messages during the init phase 
> where it's supposed to fail?
> The thing about that particular commit is it could possibly break 
> background polling, but I don't see (yet) how it could have damaged the 
> activation code. Have you tried to reboot a system where any operation 
> like: pvmove, lvconvert --merge or lvconvert mirror conversion was in 
> progress in background before you rebooted the system by any chance?

No. And I see this on different systems. It's perfectly reproducable.

> Second step would be to unmute the eventual background processes spawned 
> during activation. To do it just uncomment
> // #define DEBUG_CHILD
> in tools/toollib.c:76 lvm2 sources and rebuild.
> This should expose all error messages from within the forked off 
> processes.

Defining DEBUG_CHILD does not bring any changes... Not sure where output goes
if there is any.

However it looks like the issue is not in lvmetad itself but triggers one
in lvm. lvmetad is running with pid 69, but I see a log entry about
segmentation fault of pid 121:

lvm[121]: segfault at 58 ip 00007f2f24197d20 sp 00007ffe3b499b18 error 4 in

Not sure what command lvm is running, though. Probably pvscan, no?

BTW, if I run 'vgchange -ay' (well, actually 'lvm vgchange -ay' as it is a
multicall binary) in rescue shell the volumes are activated and boot

> Also, if you could perhaps give me some hints how to get the 
> Arch Linux in the same state as when you experienced the issue it would 
> help us as well.

I could upload a disk image that demonstrates the issue... Any preferences
about the format?
main(a){char*c=/*    Schoene Gruesse                         */"B?IJj;MEH"
"CX:;",b;for(a/*    Chris           get my mail address:    */=0;b=c[a++];)
putchar(b-1/(/*               gcc -o sig sig.c && ./sig    */b/42*2-3)*42);}
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20150521/661aba29/attachment.sig>

More information about the linux-lvm mailing list