[linux-lvm] device failure during pvmove

Bryan Larsen bryan at larsen.st
Fri Jan 15 02:29:59 UTC 2016

On Thu, 14 Jan 2016 at 20:38 Bryan Larsen <bryan at larsen.st> wrote:

> I was in the process of doing a pvmove from /dev/md3 to a new, blank
> /dev/md1 when /dev/md1 failed due to operator stupidity.
> I tried doing a pvmove abort, but it complains about a missing device.
> It suggests doing a vgreduce --removemissing but that refuses to proceed
> without a --force because pvmove has placed data onto the broken and
> missing /dev/md1.
> So theoretically all my data should still be available on /dev/md3.   Any
> hints on how to proceed?

I solved the problem.   I did a vgcfgdump, carefully edited the resulting
file, and used vgcfgrestore to bring things back to life.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20160115/6309e85b/attachment.htm>

More information about the linux-lvm mailing list