[linux-lvm] device failure during pvmove

Zdenek Kabelac zkabelac at redhat.com
Fri Jan 15 11:53:32 UTC 2016

Dne 15.1.2016 v 03:29 Bryan Larsen napsal(a):
> On Thu, 14 Jan 2016 at 20:38 Bryan Larsen <bryan at larsen.st
> <mailto:bryan at larsen.st>> wrote:
>     I was in the process of doing a pvmove from /dev/md3 to a new, blank
>     /dev/md1 when /dev/md1 failed due to operator stupidity.
>     I tried doing a pvmove abort, but it complains about a missing device.
>     It suggests doing a vgreduce --removemissing but that refuses to proceed
>     without a --force because pvmove has placed data onto the broken and
>     missing /dev/md1.
>     So theoretically all my data should still be available on /dev/md3.   Any
>     hints on how to proceed?
> I solved the problem.   I did a vgcfgdump, carefully edited the resulting
> file, and used vgcfgrestore to bring things back to life.

If you have enabled  archiving - you could use archived metadata before
you started pvmove.

Also if you have 'recent enough' version of lvm2 -  check '--atomic' option
for pvmove.



More information about the linux-lvm mailing list