[Pulp-list] Stuck repo sync job

Richard Grainger grainger at gmail.com
Thu Mar 31 10:49:18 UTC 2016

When Pulp (very occasionally) gets itself in a bit of a mess, I find
this one-liner useful:

  for ID in `pulp-admin tasks list | grep 'Task Id' | sed 's/Task
Id:\s*//g'`; do pulp-admin tasks cancel --task-id=$ID; done;

It cancels all current/pending tasks.

On Wed, Mar 30, 2016 at 10:58 PM, Matthew Madey <mattmadey at gmail.com> wrote:
> I have a job that mistakenly thinks it's still running..
> # pulp-admin -u admin -p ************ rpm repo sync run
> --repo-id=rhel-x86_64-server-7-base-tools
> +----------------------------------------------------------------------+
>        Synchronizing Repository [rhel-x86_64-server-7-base-tools]
> +----------------------------------------------------------------------+
> A sync task is already in progress for this repository. Its progress will be
> tracked below.
> This command may be exited via ctrl+c without affecting the request.
> [/]
> Waiting to begin...
> I checked all running processes and there is no repo sync currently running.
> I have even gone so far as to delete the repo and recreate it.. same issue.
> I have also tried running pulp-admin orphan remove --all, which executes
> successfully, but does not fix the problem. I have also tried rebooting the
> server, bouncing all pulp services.. still no joy. I'm guessing there is a
> file somewhere that tracks pending tasks? How can I clear this so I can
> successfully run the job again? I'm running Pulp 2.7.1-1
> _______________________________________________
> Pulp-list mailing list
> Pulp-list at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-list

More information about the Pulp-list mailing list