CUPS printing via the network

Mark Knecht markknecht at
Tue Jun 14 01:36:20 UTC 2005

On 6/13/05, Mark Knecht <markknecht at> wrote:
> Hi,
>    I have a working CUPS printer on a default install FC2 machine. I
> would like to share this printer via CUPS with other Linux machines on
> the network. CUPS appears from the manual to support this so I've
> tried setting it up on my client. I've told CUPS on my remote desktop
> that the printer is an Internet Printing Protocol printer and I've
> tried both of these options for an address of the printer:
> http://Christmas:631/ipp
> ipp://Christmas:631/ipp
> but in both cases CUPS on my client end tells me the printer is busy
> and the printer never prints anything.
>    What am I doing wrong?
>    Could a problem like this be caused by a firewall running on
> Christmas? If so what's the process of correctly opening up a port for
> this to work.
>    Does the default FC installation make printers visible on the
> network as per the CUPS manual?

No luck with this yet. The online instructions I can find talk about
enabling Broswing so I've uncommented that on both the server and the
client. The instructions say that everyone will 'see' the other
printers automatically, but they don't seem to mention what 'see'
really means. They do not show up in my printer chooser dialog boxes
on either the FC2 machines of the Gentoo machines so I cannot tell
what they think is going on. I've tried adding the printer like I
showed aboe. When I do that I get no info in the log files on either
end. I've set the the logging level to debug and cannot even see any
new network oriented messages showing up in the log files.

I've also tried linking to the Epson printer onthe FC2 machine or the
cups-pdf printer on the gentoo box. Neither does anything so far.

This all sounds so matter of fact in the CUPs manual that I expected
it to be quite easy. So much for expectations.

Thanks in advance,

More information about the Redhat-install-list mailing list