CUPS printing via the network

Rick Stevens rstevens at
Tue Jun 14 02:12:03 UTC 2005

Mark Knecht wrote:
> On 6/13/05, Mark Knecht <markknecht at> wrote:
>>   I have a working CUPS printer on a default install FC2 machine. I
>>would like to share this printer via CUPS with other Linux machines on
>>the network. CUPS appears from the manual to support this so I've
>>tried setting it up on my client. I've told CUPS on my remote desktop
>>that the printer is an Internet Printing Protocol printer and I've
>>tried both of these options for an address of the printer:
>>but in both cases CUPS on my client end tells me the printer is busy
>>and the printer never prints anything.
>>   What am I doing wrong?
>>   Could a problem like this be caused by a firewall running on
>>Christmas? If so what's the process of correctly opening up a port for
>>this to work.
>>   Does the default FC installation make printers visible on the
>>network as per the CUPS manual?
> No luck with this yet. The online instructions I can find talk about
> enabling Broswing so I've uncommented that on both the server and the
> client. The instructions say that everyone will 'see' the other
> printers automatically, but they don't seem to mention what 'see'
> really means. They do not show up in my printer chooser dialog boxes
> on either the FC2 machines of the Gentoo machines so I cannot tell
> what they think is going on. I've tried adding the printer like I
> showed aboe. When I do that I get no info in the log files on either
> end. I've set the the logging level to debug and cannot even see any
> new network oriented messages showing up in the log files.
> I've also tried linking to the Epson printer onthe FC2 machine or the
> cups-pdf printer on the gentoo box. Neither does anything so far.
> This all sounds so matter of fact in the CUPs manual that I expected
> it to be quite easy. So much for expectations.

Run "system-config-printer" on the CUPS server.  When it comes up,
right click on the printer you're trying to share and select
"Sharing..."  Make sure the "This queue is available to other printers"
option is checked, then put in the appropriate "Allowed Hosts" IP stuff.
For example, for my entire firewalled /24 network, I have
"" in there.  Save the changes, then click on
the "Apply" button.

Once the CUPS system restarts, go to one of the clients and also run
system-config-printer.  Click on the "Browsed Queues" thing and you
should see the printer in there.  Select it and you're ready to go.
- Rick Stevens, Senior Systems Engineer     rstevens at -
- VitalStream, Inc.              -
-                                                                    -
-                  Heisenberg _may_ have slept here                  -

More information about the Redhat-install-list mailing list